import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=<p>).*?(?=<\\/p>)";
final String string = "<p>Hello !</p> <p>I wont select tags! Only text with in</p>\n"
+ "<p>Hello !</p> <p>I wont select tags! Only text with in</p>\n"
+ "<p>Hello !</p> <p>I wont select tags! Only text with in</p>\n"
+ "<p>Hello !</p> <p>I wont select tags! Only text with in</p>";
final String subst = "replace me";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}