use strict;
my $str = '<p>Hello !</p> <p>I wont select tags! Only text with in</p>
<p>Hello !</p> <p>I wont select tags! Only text with in</p>
<p>Hello !</p> <p>I wont select tags! Only text with in</p>
<p>Hello !</p> <p>I wont select tags! Only text with in</p>';
my $regex = qr@(?<=<p>).*?(?=<\/p>)@sp;
my $subst = 'replace me';
my $result = $str =~ s@$regex@$subst@rg;
print "The result of the substitution is' $result\n";