using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?![a-z]*([a-z])([a-z])\2\1[a-z]*\b)[a-z]+\b";
string input = @"This is a regex that matches everything i want to exclude, which is words like abba, trillion ";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}