const regex = /\b(?![a-z]*([a-z])([a-z])\2\1[a-z]*\b)[a-z]+\b/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?![a-z]*([a-z])([a-z])\\2\\1[a-z]*\\b)[a-z]+\\b', 'gi')
const str = `This is a regex that matches everything i want to exclude, which is words like abba, trillion `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}