package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^\/en-gb\/company\/?$`)
var str = `/en-gb/company/stats/something
/en-gb/company/stats/
/en-gb/company/stats
/en-gb/company/stats
/en-gb/company
/en-gb/company/
/en-gb/company/something`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}