$re = '/^\/en-gb\/company\/?$/im';
$str = '/en-gb/company/stats/something
/en-gb/company/stats/
/en-gb/company/stats
/en-gb/company/stats
/en-gb/company
/en-gb/company/
/en-gb/company/something';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);