// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)^\/en-gb\/company\/?$").unwrap();
let string = "/en-gb/company/stats/something
/en-gb/company/stats/
/en-gb/company/stats
/en-gb/company/stats
/en-gb/company
/en-gb/company/
/en-gb/company/something";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}