const regex = /(.*)\*/m;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*)\\*', 'm')
const str = `Field Name* * `;
const subst = `$1mandatory`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);