$re = '/(.*)\*/m';
$str = 'Field Name* * ';
$subst = "$1mandatory";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;