package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[TEST\d[^[]+\]`)
var str = `[TEST1 lorem ipsum123][TEST2 lorem ipsum123][TEST3 lorem ipsum123]Test4`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}