re = /\[TEST\d[^[]+\]/m
str = '[TEST1 lorem ipsum123][TEST2 lorem ipsum123][TEST3 lorem ipsum123]Test4'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end