$re = '/\[TEST\d[^[]+\]/m';
$str = '[TEST1 lorem ipsum123][TEST2 lorem ipsum123][TEST3 lorem ipsum123]Test4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);