import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(19\\d{2}|2\\d{3})-((0[13578]|1[02])-([0-2]\\d|3[01])|02-[0-2]\\d|(0[469]|11)-([0-2]\\d|30))T([01]\\d|2[0-4])(:[0-5]\\d){2}(\\.\\d{3})?(Z|([+-]([01]\\d|2[0-3]):[0-5]\\d))$";
final String string = "2999-12-31T23:59:59.999+23:59\n"
+ "1900-01-01T00:00:00.000-23:59";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}