#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\[(\[?)(embed|wp_caption|caption|gallery|playlist|audio|video|code_snippet|democracy|democracy_archives|download)(?![\w-])([^\]\/]*(?:\/(?!\])[^\]\/]*)*?)(?:(\/)\]|\](?:([^\[]*+(?:\[(?!\/\2\])[^\[]*+)*+)\[\/\2\])?)(\]?)"
Local $sString = "[caption id="attachment_33674" align="aligncenter" width="900"]<a href="http://barnaul.press/wp-content/uploads/2021/02/IMG_9329.jpg"><img class="size-full wp-image-33674" src="http://barnaul.press/wp-content/uploads/2021/02/IMG_9329.jpg" alt="" width="900" height="600" /></a> В составе "Снежного десанта" участвовали два отряда ветеранов движения из числа бывших студентов.<br />Фото Михаила Полубедова[/caption]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")