const regex = /\[(\[?)(embed|wp_caption|caption|gallery|playlist|audio|video|code_snippet|democracy|democracy_archives|download)(?![\w-])([^\]\/]*(?:\/(?!\])[^\]\/]*)*?)(?:(\/)\]|\](?:([^\[]*+(?:\[(?!\/\2\])[^\[]*+)*+)\[\/\2\])?)(\]?)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[(\\[?)(embed|wp_caption|caption|gallery|playlist|audio|video|code_snippet|democracy|democracy_archives|download)(?![\\w-])([^\\]\\\/]*(?:\\\/(?!\\])[^\\]\\\/]*)*?)(?:(\\\/)\\]|\\](?:([^\\[]*+(?:\\[(?!\\\/\\2\\])[^\\[]*+)*+)\\[\\\/\\2\\])?)(\\]?)', 'gm')
const str = `[caption id="attachment_33674" align="aligncenter" width="900"]<a href="http://barnaul.press/wp-content/uploads/2021/02/IMG_9329.jpg"><img class="size-full wp-image-33674" src="http://barnaul.press/wp-content/uploads/2021/02/IMG_9329.jpg" alt="" width="900" height="600" /></a> В составе "Снежного десанта" участвовали два отряда ветеранов движения из числа бывших студентов.<br />Фото Михаила Полубедова[/caption]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}