use strict;
my $str = 'zeit.BUCHUNGSTAG=[2017-11-01T00%3A00%3A00;2018-02-01T23%3A59%3A59]&_viewjoins=zeit|ba|ma|p&p.PERSONAL=in[deil_felix;lechner_carina]&fdf=dfuebfek
p.PERSONAL=in[deil_felix;lechner_carina]&zeit.BUCHUNGSTAG=[2017-11-01T00%3A00%3A00;2018-02-01T23%3A59%3A59]&_viewjoins=zeit|ba|ma|p';
my $regex = qr/(.*)p\.PERSONAL=[^&]*(.*)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}