#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?=.*[A-Z].*[A-Z])|(?=.*\d))[A-Za-z0-9\/-]+$"
Local $sString = "ametFXUT0" & @CRLF & _
"G197-6STK" & @CRLF & _
"adipiscXWWFHH" & @CRLF & _
"A654/9023847" & @CRLF & _
"HYJ/54GFJ" & @CRLF & _
"hgdy67h" & @CRLF & _
"abc" & @CRLF & _
"Aabdfjfkk"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")