re = /^(?:(?=.*[A-Z].*[A-Z])|(?=.*\d))[A-Za-z0-9\/-]+$/m
str = 'ametFXUT0
G197-6STK
adipiscXWWFHH
A654/9023847
HYJ/54GFJ
hgdy67h
abc
Aabdfjfkk'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end