$re = '/^(?:(?=.*[A-Z].*[A-Z])|(?=.*\d))[A-Za-z0-9\/-]+$/m';
$str = 'ametFXUT0
G197-6STK
adipiscXWWFHH
A654/9023847
HYJ/54GFJ
hgdy67h
abc
Aabdfjfkk';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);