use strict;
my $str = 'Here is a line of text that I DON\'T want to match.
Here is a line of text that I DO want to match.
Here is a line of text that I DO want to match.
String to match
Line of text and numbers and other marks abc123:/()& that I want to capture.
Line of text and numbers and other marks abc123:/()& that I want to capture.
Line of text and numbers and other marks abc123:/()& that I want to capture.
String to end on but NOT capture
text I DON\'T want
text I DON\'T want';
my $regex = qr/(?=(.+\n){2}String to match)[\w\W]+(?=String to end on but NOT capture)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}