import Foundation
let pattern = #"(?=(.+\n){2}String to match)[\w\W]+(?=String to end on but NOT capture)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Here is a line of text that I DON'T want to match.
Here is a line of text that I DO want to match.
Here is a line of text that I DO want to match.
String to match
Line of text and numbers and other marks abc123:/()& that I want to capture.
Line of text and numbers and other marks abc123:/()& that I want to capture.
Line of text and numbers and other marks abc123:/()& that I want to capture.
String to end on but NOT capture
text I DON'T want
text I DON'T want
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)