re = /(?=(.+\n){2}String to match)[\w\W]+(?=String to end on but NOT capture)/m
str = 'Here is a line of text that I DON\'T want to match.
Here is a line of text that I DO want to match.
Here is a line of text that I DO want to match.
String to match
Line of text and numbers and other marks abc123:/()& that I want to capture.
Line of text and numbers and other marks abc123:/()& that I want to capture.
Line of text and numbers and other marks abc123:/()& that I want to capture.
String to end on but NOT capture
text I DON\'T want
text I DON\'T want'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end