package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d{4})-(\d{2})(A)?-(\d{2})`)
var str = ` 2016-01-11 and some text and 2017-02A-22`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}