$re = '/(\d{4})-(\d{2})(A)?-(\d{2})/u';
$str = ' 2016-01-11 and some text and 2017-02A-22';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);