re = /(\d{4})-(\d{2})(A)?-(\d{2})/
str = ' 2016-01-11 and some text and 2017-02A-22'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end