#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(--([A-z\-]*?):(?<!--rgb:)).*?;"
Local $sString = "  --color-primary: #0017a8;" & @CRLF & _
                "  --color-primary--rgb: #{hexToRGB(color-primary)};" & @CRLF & _
                "  --variablename: blabla blablabla;" & @CRLF & _
                "  --color-secondary: #0631ff;" & @CRLF & _
                "  --color-secondary--rgb: #{hexToRGB(color-secondary)};" & @CRLF & _
                "  --color-tertiary: #00ffe0;" & @CRLF & _
                "  --color-tertiary--rgb: #{hexToRGB(color-tertiary)};" & @CRLF & _
                "  --color-green-dark: #257426;" & @CRLF & _
                "  --color-green-dark--rgb: #{hexToRGB(color-green-dark)};" & @CRLF & _
                "" & @CRLF & _
                "  --font-family: TTCommons, Helvetica, Arial, sans-serif;" & @CRLF & _
                "  --transition: 0.3s ease;" & @CRLF & _
                "  --box-shadow: 0 0 12px 0 rgba(0, 0, 0, 0.3);"
Local $sSubst = "$1 #{$$$2};"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)