import re
regex = re.compile(r"(--([A-z\-]*?):(?<!--rgb:)).*?;", flags=re.MULTILINE)
test_str = (" --color-primary: #0017a8;\n"
" --color-primary--rgb: #{hexToRGB(color-primary)};\n"
" --variablename: blabla blablabla;\n"
" --color-secondary: #0631ff;\n"
" --color-secondary--rgb: #{hexToRGB(color-secondary)};\n"
" --color-tertiary: #00ffe0;\n"
" --color-tertiary--rgb: #{hexToRGB(color-tertiary)};\n"
" --color-green-dark: #257426;\n"
" --color-green-dark--rgb: #{hexToRGB(color-green-dark)};\n\n"
" --font-family: TTCommons, Helvetica, Arial, sans-serif;\n"
" --transition: 0.3s ease;\n"
" --box-shadow: 0 0 12px 0 rgba(0, 0, 0, 0.3);")
subst = "$1 #{$$$2};"
result = regex.sub(subst, test_str)
if result:
print(result)