import Foundation
let pattern = #"(--([A-z\-]*?):(?<!--rgb:)).*?;"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
--color-primary: #0017a8;
--color-primary--rgb: #{hexToRGB(color-primary)};
--variablename: blabla blablabla;
--color-secondary: #0631ff;
--color-secondary--rgb: #{hexToRGB(color-secondary)};
--color-tertiary: #00ffe0;
--color-tertiary--rgb: #{hexToRGB(color-tertiary)};
--color-green-dark: #257426;
--color-green-dark--rgb: #{hexToRGB(color-green-dark)};
--font-family: TTCommons, Helvetica, Arial, sans-serif;
--transition: 0.3s ease;
--box-shadow: 0 0 12px 0 rgba(0, 0, 0, 0.3);
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = ##"$1 #{$$$2};"##
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)