// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)stone *variant=([^\s]*)").unwrap();
let string = "setblock ~ ~ ~ minecraft:stone variant=granite aadsdasdsad
execute @e[type=ArmorStand] ~ ~ ~ setblock ~ ~ ~ minecraft:stone variant=granite
";
let substitution = "stone 1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}