using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\[)([一-龠])?([ぁ-ん])?([一-龠])?([ぁ-ん]{1,4})?[一-龠]?([ァ-ヴー]+|([ぁ-ん]{1,2}))?(う|く|す|つ|ぬ|ふ|む|る|ぐ|ぶ)(\-(他|自)動詞)?(?=\]\|は)";
string input = @"目指す[目指す]|は[は] 国家[国家]|資格[資格]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}