import re
regex = re.compile(r"(?<=\[)([一-龠])?([ぁ-ん])?([一-龠])?([ぁ-ん]{1,4})?[一-龠]?([ァ-ヴー]+|([ぁ-ん]{1,2}))?(う|く|す|つ|ぬ|ふ|む|る|ぐ|ぶ)(\-(他|自)動詞)?(?=\]\|は)", flags=re.MULTILINE)
test_str = "目指す[目指す]|は[は] 国家[国家]|資格[資格]"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")