package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bIP\([^()]*\):Y\([^()]*\)`)
var str = `show run IP(k1) new Y(y1) add IP(dev.maintserial):Y(dev.maintkeys)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}