// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\bIP\([^()]*\):Y\([^()]*\)").unwrap();
let string = "show run IP(k1) new Y(y1) add IP(dev.maintserial):Y(dev.maintkeys)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}