$re = '/\bIP\([^()]*\):Y\([^()]*\)/m';
$str = 'show run IP(k1) new Y(y1) add IP(dev.maintserial):Y(dev.maintkeys)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);