import re
regex = re.compile(r"<\s*(/?)\s*(?!(?:a|strong|em)\b)(\w+[^>]*)>")
test_str = ("<a href=\"https://www.example.com/page\">Example page</a> is a <strong>valid</strong> tag.\n"
"< em class=\"something\"> is also allowed</em>\n"
"But <param> or <argument> should be escaped.\n"
"This also: <br/> <\n"
"br /> <script type=\"text/javascript\">alert('xss'></script>")
subst = "<\\1\\2>"
result = regex.sub(subst, test_str)
if result:
print(result)