import Foundation
let pattern = #"<\s*(/?)\s*(?!(?:a|strong|em)\b)(\w+[^>]*)>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<a href="https://www.example.com/page">Example page</a> is a <strong>valid</strong> tag.
< em class="something"> is also allowed</em>
But <param> or <argument> should be escaped.
This also: <br/> <
br /> <script type="text/javascript">alert('xss'></script>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<\1\2>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)