const regex = new RegExp('<\\s*(/?)\\s*(?=(?:a|strong|em)\\b)(\\w+[^>]*)>', 'g')
const str = `<a href="https://www.example.com/page">Example page</a> is a <strong>valid</strong> tag.
< em class="something"> is also allowed</em>
But <param> or <argument> should be escaped.
This also: <br/> <
br /> <script type="text/javascript">alert('xss'></script>
Turn left <- or turn right ->
Also, accept this => or a smiley >.<`;
const subst = `[\1\2]`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);