$re = '/<\s*(/?)\s*(?=(?:a|strong|em)\b)(\w+[^>]*)>/';
$str = '<a href="https://www.example.com/page">Example page</a> is a <strong>valid</strong> tag.
< em class="something"> is also allowed</em>
But <param> or <argument> should be escaped.
This also: <br/> <
br /> <script type="text/javascript">alert(\'xss\'></script>
Turn left <- or turn right ->
Also, accept this => or a smiley >.<';
$subst = "[\1\2]";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;