use strict;
my $str = '<a href="https://www.example.com/page">Example page</a> is a <strong>valid</strong> tag.
< em class="something"> is also allowed</em>
But <param> or <argument> should be escaped.
This also: <br/> <
br /> <script type="text/javascript">alert(\'xss\'></script>
Turn left <- or turn right ->
Also, accept this => or a smiley >.<';
my $regex = qr/<\s*(/?)\s*(?=(?:a|strong|em)\b)(\w+[^>]*)>/p;
my $subst = '[\\1\\2]';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";