using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<a>a:(?<av>[^,]+))[^c]+(?<c>c:(?<cv>[^,]+))";
string input = @"[{a:1,b:2,c:3,d:4},{a:10,b:20,c:30,d:40},{a:100,b:200,c:300,d:400}]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}