$re = '/(?<a>a:(?<av>[^,]+))[^c]+(?<c>c:(?<cv>[^,]+))/';
$str = '[{a:1,b:2,c:3,d:4},{a:10,b:20,c:30,d:40},{a:100,b:200,c:300,d:400}]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);