const regex = /(?<a>a:(?<av>[^,]+))[^c]+(?<c>c:(?<cv>[^,]+))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<a>a:(?<av>[^,]+))[^c]+(?<c>c:(?<cv>[^,]+))', 'g')
const str = `[{a:1,b:2,c:3,d:4},{a:10,b:20,c:30,d:40},{a:100,b:200,c:300,d:400}]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}