using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(-?((0|[1-9]+)\.\d{1,4}|[1-9])|0)$";
string input = @"Acceptable:
0
0.1
0.12
0.123
0.1234
1
1.1
...
123456789.1234
-0.1
-0.12
-0.123
-0.1234
-1
-1.1
...
-123456789.1234
No
-123456789.123456789
-
+
-0
0123456789.1234
007
+0.1
+123456789.1234
.1234
1.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}