$re = '/^(-?((0|[1-9]+)\.\d{1,4}|[1-9])|0)$/m';
$str = 'Acceptable:
0
0.1
0.12
0.123
0.1234
1
1.1
...
123456789.1234
-0.1
-0.12
-0.123
-0.1234
-1
-1.1
...
-123456789.1234
No
-123456789.123456789
-
+
-0
0123456789.1234
007
+0.1
+123456789.1234
.1234
1.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);