// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(-?((0|[1-9]+)\.\d{1,4}|[1-9])|0)$").unwrap();
let string = "Acceptable:
0
0.1
0.12
0.123
0.1234
1
1.1
...
123456789.1234
-0.1
-0.12
-0.123
-0.1234
-1
-1.1
...
-123456789.1234
No
-123456789.123456789
-
+
-0
0123456789.1234
007
+0.1
+123456789.1234
.1234
1.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}