#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\,[^.]+\}"
Local $sString = "{" & @CRLF & _
" "markers": [" & @CRLF & _
" {" & @CRLF & _
" "name": "Rixos The Palm Dubai"," & @CRLF & _
" "position": [25.1212, 55.1535]," & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "name": "Shangri-La Hotel"," & @CRLF & _
" "description": "some description"," & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "value": 123445," & @CRLF & _
" }" & @CRLF & _
" ]" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")