using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\,[^.]+\}";
string input = @"{
""markers"": [
{
""name"": ""Rixos The Palm Dubai"",
""position"": [25.1212, 55.1535],
},
{
""name"": ""Shangri-La Hotel"",
""description"": ""some description"",
},
{
""value"": 123445,
}
]
}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}