re = /\,[^.]+\}/m
str = '{
"markers": [
{
"name": "Rixos The Palm Dubai",
"position": [25.1212, 55.1535],
},
{
"name": "Shangri-La Hotel",
"description": "some description",
},
{
"value": 123445,
}
]
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end