const regex = /[0-9A-F][0-9A-F][0-9A-F]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[0-9A-F][0-9A-F][0-9A-F]', 'gm')
const str = `1H8 4E2 8FF 0P1 T8B 776 42B G12`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}