// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[0-9A-F][0-9A-F][0-9A-F]").unwrap();
let string = "1H8 4E2 8FF 0P1 T8B 776 42B G12";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}